Get in touch
Back
Resolved

DNS was malconfigured for 6 minutes.

Started 3 Oct at 10:48am CEST.

OnRoute OnShift OnPick
Created

The issue was fixed

Posted 3 Oct at 10:48am CEST.